import Foundation
let pattern = #"((?<![\\])['"])((?:.(?!(?<![\\])\1))*.?)\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"/a:"value" -big="this -test:1\"23 is & $#@ _ y\"\"our life" -test=th_3"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)