using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<![\\])['""])((?:.(?!(?<![\\])\1))*.?)\1";
string substitution = @"";
string input = @"/a:""value"" -big=""this -test:1\""23 is & $#@ _ y\""\""our life"" -test=th_3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}