use strict;
my $str = '/a:"value" -big="this -test:1\\"23 is & $#@ _ y\\"\\"our life" -test=th_3';
my $regex = qr/((?<![\\])['"])((?:.(?!(?<![\\])\1))*.?)\1/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";