const regex = /((?<![\\])['"])((?:.(?!(?<![\\])\1))*.?)\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<![\\\\])[\'"])((?:.(?!(?<![\\\\])\\1))*.?)\\1', 'g')
const str = `/a:"value" -big="this -test:1\\"23 is & \$#@ _ y\\"\\"our life" -test=th_3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);