$re = '/((?<![\\\\])[\'"])((?:.(?!(?<![\\\\])\1))*.?)\1/';
$str = '/a:"value" -big="this -test:1\\"23 is & $#@ _ y\\"\\"our life" -test=th_3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;