#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?<![\\])['"])((?:.(?!(?<![\\])\1))*.?)\1"
Local $sString = "/a:"value" -big="this -test:1\"23 is & $#@ _ y\"\"our life" -test=th_3"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)