#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s?\S+\sOk"
Local $sString = "@datsmanx Ok" & @CRLF & _
"@exclusiv4ik_41 Ok" & @CRLF & _
"@valery19800 Ok" & @CRLF & _
"@kichah Ok" & @CRLF & _
"@nikolaj1922 Ok" & @CRLF & _
"@jacpot555 Ok" & @CRLF & _
"@artem_ozerov Ok" & @CRLF & _
"@myslyslyshym" & @CRLF & _
"@polll4 Ok" & @CRLF & _
"@sundayhotpizza" & @CRLF & _
"@sergeymrum Ok" & @CRLF & _
"@drugdrugan Ok" & @CRLF & _
"@tsarev_alexander NotFound" & @CRLF & _
"@aleksey1988aa Ok" & @CRLF & _
"@vadim34vv Ok" & @CRLF & _
"@voronidzeantoni Ok" & @CRLF & _
"@briz8668 Ok" & @CRLF & _
"@ivan_poker Ok" & @CRLF & _
"@pro100stalker007 NotFound" & @CRLF & _
"@andaway3342 Ok" & @CRLF & _
"@erzho Ok" & @CRLF & _
"@cenzor_333 NotFound" & @CRLF & _
"@kap1o" & @CRLF & _
"@samadovtarget Ok" & @CRLF & _
"@akol75 Ok" & @CRLF & _
"@ilya89nt" & @CRLF & _
"@onetimeusername Ok" & @CRLF & _
"@ilya_gordovsky Ok"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")