# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s?\S+\sOk"
test_str = ("@datsmanx Ok\n"
"@exclusiv4ik_41 Ok\n"
"@valery19800 Ok\n"
"@kichah Ok\n"
"@nikolaj1922 Ok\n"
"@jacpot555 Ok\n"
"@artem_ozerov Ok\n"
"@myslyslyshym\n"
"@polll4 Ok\n"
"@sundayhotpizza\n"
"@sergeymrum Ok\n"
"@drugdrugan Ok\n"
"@tsarev_alexander NotFound\n"
"@aleksey1988aa Ok\n"
"@vadim34vv Ok\n"
"@voronidzeantoni Ok\n"
"@briz8668 Ok\n"
"@ivan_poker Ok\n"
"@pro100stalker007 NotFound\n"
"@andaway3342 Ok\n"
"@erzho Ok\n"
"@cenzor_333 NotFound\n"
"@kap1o\n"
"@samadovtarget Ok\n"
"@akol75 Ok\n"
"@ilya89nt\n"
"@onetimeusername Ok\n"
"@ilya_gordovsky Ok")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.