import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s?\\S+\\sOk";
final String string = "@datsmanx Ok\n"
+ "@exclusiv4ik_41 Ok\n"
+ "@valery19800 Ok\n"
+ "@kichah Ok\n"
+ "@nikolaj1922 Ok\n"
+ "@jacpot555 Ok\n"
+ "@artem_ozerov Ok\n"
+ "@myslyslyshym\n"
+ "@polll4 Ok\n"
+ "@sundayhotpizza\n"
+ "@sergeymrum Ok\n"
+ "@drugdrugan Ok\n"
+ "@tsarev_alexander NotFound\n"
+ "@aleksey1988aa Ok\n"
+ "@vadim34vv Ok\n"
+ "@voronidzeantoni Ok\n"
+ "@briz8668 Ok\n"
+ "@ivan_poker Ok\n"
+ "@pro100stalker007 NotFound\n"
+ "@andaway3342 Ok\n"
+ "@erzho Ok\n"
+ "@cenzor_333 NotFound\n"
+ "@kap1o\n"
+ "@samadovtarget Ok\n"
+ "@akol75 Ok\n"
+ "@ilya89nt\n"
+ "@onetimeusername Ok\n"
+ "@ilya_gordovsky Ok";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}