use strict;
my $str = '@datsmanx Ok
@exclusiv4ik_41 Ok
@valery19800 Ok
@kichah Ok
@nikolaj1922 Ok
@jacpot555 Ok
@artem_ozerov Ok
@myslyslyshym
@polll4 Ok
@sundayhotpizza
@sergeymrum Ok
@drugdrugan Ok
@tsarev_alexander NotFound
@aleksey1988aa Ok
@vadim34vv Ok
@voronidzeantoni Ok
@briz8668 Ok
@ivan_poker Ok
@pro100stalker007 NotFound
@andaway3342 Ok
@erzho Ok
@cenzor_333 NotFound
@kap1o
@samadovtarget Ok
@akol75 Ok
@ilya89nt
@onetimeusername Ok
@ilya_gordovsky Ok';
my $regex = qr/^\s?\S+\sOk/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}