using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s?\S+\sOk";
string input = @"@datsmanx Ok
@exclusiv4ik_41 Ok
@valery19800 Ok
@kichah Ok
@nikolaj1922 Ok
@jacpot555 Ok
@artem_ozerov Ok
@myslyslyshym
@polll4 Ok
@sundayhotpizza
@sergeymrum Ok
@drugdrugan Ok
@tsarev_alexander NotFound
@aleksey1988aa Ok
@vadim34vv Ok
@voronidzeantoni Ok
@briz8668 Ok
@ivan_poker Ok
@pro100stalker007 NotFound
@andaway3342 Ok
@erzho Ok
@cenzor_333 NotFound
@kap1o
@samadovtarget Ok
@akol75 Ok
@ilya89nt
@onetimeusername Ok
@ilya_gordovsky Ok";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}