const regex = /^\s?\S+\sOk/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s?\\S+\\sOk', 'gm')
const str = `@datsmanx Ok
@exclusiv4ik_41 Ok
@valery19800 Ok
@kichah Ok
@nikolaj1922 Ok
@jacpot555 Ok
@artem_ozerov Ok
@myslyslyshym
@polll4 Ok
@sundayhotpizza
@sergeymrum Ok
@drugdrugan Ok
@tsarev_alexander NotFound
@aleksey1988aa Ok
@vadim34vv Ok
@voronidzeantoni Ok
@briz8668 Ok
@ivan_poker Ok
@pro100stalker007 NotFound
@andaway3342 Ok
@erzho Ok
@cenzor_333 NotFound
@kap1o
@samadovtarget Ok
@akol75 Ok
@ilya89nt
@onetimeusername Ok
@ilya_gordovsky Ok`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}