package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w{0,8})\s*(\w+)\s*(\w{3})(\w{3})$`)
var str = `508815 AYBK1619RAUEZP
AWBZ4222TYBE1207CWSWER
DEFAULT EP1 O25R60`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}