re = /^(\w{0,8})\s*(\w+)\s*(\w{3})(\w{3})$/m
str = '508815 AYBK1619RAUEZP
AWBZ4222TYBE1207CWSWER
DEFAULT EP1 O25R60'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end