import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w{0,8})\\s*(\\w+)\\s*(\\w{3})(\\w{3})$";
final String string = "508815 AYBK1619RAUEZP\n"
+ "AWBZ4222TYBE1207CWSWER\n"
+ "DEFAULT EP1 O25R60";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}