const regex = /^(\w{0,8})\s*(\w+)\s*(\w{3})(\w{3})$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w{0,8})\\s*(\\w+)\\s*(\\w{3})(\\w{3})$', 'mg')
const str = `508815 AYBK1619RAUEZP
AWBZ4222TYBE1207CWSWER
DEFAULT EP1 O25R60`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}