import re
regex = re.compile(r"^(\w{0,8})\s*(\w+)\s*(\w{3})(\w{3})$", flags=re.MULTILINE)
test_str = ("508815 AYBK1619RAUEZP\n"
"AWBZ4222TYBE1207CWSWER\n"
"DEFAULT EP1 O25R60")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")