#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[[:digit:]]+ Bytes |\[|\]"
Local $sString = "200000 Bytes [250 GB]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)