const regex = /[[:digit:]]+ Bytes |\[|\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[[:digit:]]+ Bytes |\\[|\\]', 'g')
const str = `200000 Bytes [250 GB]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);