using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[:digit:]]+ Bytes |\[|\]";
string substitution = @"";
string input = @"200000 Bytes [250 GB]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}