use strict;
my $str = '200000 Bytes [250 GB]';
my $regex = qr/[[:digit:]]+ Bytes |\[|\]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";