#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)\b[johny]+\b\s+\b[aplsed]+\b"
Local $sString = "The myth of Johnny Appleseed states that he ate many apple seeds" & @CRLF & _
"" & @CRLF & _
"#misspellings " & @CRLF & _
"Johnny Applseed" & @CRLF & _
"Johny Appleseed" & @CRLF & _
"Johnny Applesee" & @CRLF & _
"" & @CRLF & _
"#Letter case " & @CRLF & _
"johnny appleseed" & @CRLF & _
"JOHNNY APPLESEED" & @CRLF & _
"JoHny ApPleseED"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")