re = /\b[johny]+\b\s+\b[aplsed]+\b/i
str = 'The myth of Johnny Appleseed states that he ate many apple seeds
#misspellings
Johnny Applseed
Johny Appleseed
Johnny Applesee
#Letter case
johnny appleseed
JOHNNY APPLESEED
JoHny ApPleseED'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end