const regex = /\b[johny]+\b\s+\b[aplsed]+\b/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[johny]+\\b\\s+\\b[aplsed]+\\b', 'gsi')
const str = `The myth of Johnny Appleseed states that he ate many apple seeds
#misspellings
Johnny Applseed
Johny Appleseed
Johnny Applesee
#Letter case
johnny appleseed
JOHNNY APPLESEED
JoHny ApPleseED`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}