$re = '/\b[johny]+\b\s+\b[aplsed]+\b/si';
$str = 'The myth of Johnny Appleseed states that he ate many apple seeds
#misspellings
Johnny Applseed
Johny Appleseed
Johnny Applesee
#Letter case
johnny appleseed
JOHNNY APPLESEED
JoHny ApPleseED';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);