import Foundation
let pattern = #"\b[johny]+\b\s+\b[aplsed]+\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = ##"""
The myth of Johnny Appleseed states that he ate many apple seeds
#misspellings
Johnny Applseed
Johny Appleseed
Johnny Applesee
#Letter case
johnny appleseed
JOHNNY APPLESEED
JoHny ApPleseED
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)