import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[johny]+\\b\\s+\\b[aplsed]+\\b";
final String string = "The myth of Johnny Appleseed states that he ate many apple seeds\n\n"
+ "#misspellings \n"
+ "Johnny Applseed\n"
+ "Johny Appleseed\n"
+ "Johnny Applesee\n\n"
+ "#Letter case \n"
+ "johnny appleseed\n"
+ "JOHNNY APPLESEED\n"
+ "JoHny ApPleseED";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}