using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\R*$";
string substitution = @"•";
string input = @"line
line 2
line 3
NOTE: The replacement uses a bullet
instead of a LF so it is easy to see
";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}