use strict;
my $str = 'line
line 2
line 3
NOTE: The replacement uses a bullet
instead of a LF so it is easy to see
';
my $regex = qr/\R*$/up;
my $subst = '•';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";