import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\R*$";
final String string = "line \n"
+ "line 2\n"
+ "line 3\n\n"
+ "NOTE: The replacement uses a bullet \n"
+ "instead of a LF so it is easy to see\n\n\n\n";
final String subst = "•";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}