package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\R*$`)
var str = []byte(`line
line 2
line 3
NOTE: The replacement uses a bullet
instead of a LF so it is easy to see
`)
var substitution = []byte("•")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}