$re = '/\R*$/u';
$str = 'line
line 2
line 3
NOTE: The replacement uses a bullet
instead of a LF so it is easy to see
';
$subst = "•";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;