package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Umbra-[\d]{2,}+`)
var str = `Umbra-9
umbra-09
Umbra_09
Umbra09
UMBRA-09
Umbra-09
Umbra-10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}