re = /Umbra-[\d]{2,}+/m
str = 'Umbra-9
umbra-09
Umbra_09
Umbra09
UMBRA-09
Umbra-09
Umbra-10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end