import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Umbra-[\\d]{2,}+";
final String string = "Umbra-9\n"
+ "umbra-09\n"
+ "Umbra_09\n"
+ "Umbra09\n"
+ "UMBRA-09\n"
+ "Umbra-09\n"
+ "Umbra-10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}