const regex = /Umbra-[\d]{2,}+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Umbra-[\\d]{2,}+', 'gm')
const str = `Umbra-9
umbra-09
Umbra_09
Umbra09
UMBRA-09
Umbra-09
Umbra-10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}