#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(\/\/(.*?)\n)|(\/\*(.*?)\*\/)"
Local $sString = "/* комментарий */" & @CRLF & _
"" & @CRLF & _
"init: function(options)" & @CRLF & _
" {" & @CRLF & _
" opts = $.extend({}, defaults, options);" & @CRLF & _
" opts._this = $(this).attr('id');" & @CRLF & _
" opts.elementWrapper = $('#' + opts.resultItemWrapper)." & @CRLF & _
"/*" & @CRLF & _
" * комментарий" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
" prop('outerHTML')." & @CRLF & _
" replace(/\s+/g, ' ');" & @CRLF & _
"" & @CRLF & _
" $(this).children().remove();" & @CRLF & _
" $(this).css({'height': '100%'});" & @CRLF & _
"// $(this).append" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")