re = /(\/\/(.*?)\n)|(\/\*(.*?)\*\/)/m
str = '/* комментарий */
init: function(options)
{
opts = $.extend({}, defaults, options);
opts._this = $(this).attr(\'id\');
opts.elementWrapper = $(\'#\' + opts.resultItemWrapper).
/*
* комм ентарий
*/
prop(\'outerHTML\').
replace(/\\s+/g, \' \');
$(this).children().remove();
$(this).css({\'height\': \'100%\'});
// $(this).append
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end