import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\/(.*?)\\n)|(\\/\\*(.*?)\\*\\/)";
final String string = "/* комментарий */\n\n"
+ "init: function(options)\n"
+ " {\n"
+ " opts = $.extend({}, defaults, options);\n"
+ " opts._this = $(this).attr('id');\n"
+ " opts.elementWrapper = $('#' + opts.resultItemWrapper).\n"
+ "/*\n"
+ " * комментарий\n"
+ " */\n\n"
+ " prop('outerHTML').\n"
+ " replace(/\\s+/g, ' ');\n\n"
+ " $(this).children().remove();\n"
+ " $(this).css({'height': '100%'});\n"
+ "// $(this).append\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}