using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\/(.*?)\n)|(\/\*(.*?)\*\/)";
string input = @"/* комментарий */
init: function(options)
{
opts = $.extend({}, defaults, options);
opts._this = $(this).attr('id');
opts.elementWrapper = $('#' + opts.resultItemWrapper).
/*
* комментарий
*/
prop('outerHTML').
replace(/\s+/g, ' ');
$(this).children().remove();
$(this).css({'height': '100%'});
// $(this).append
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}