$re = '/(\/\/(.*?)\n)|(\/\*(.*?)\*\/)/ms';
$str = '/* комментарий */
init: function(options)
{
opts = $.extend({}, defaults, options);
opts._this = $(this).attr(\'id\');
opts.elementWrapper = $(\'#\' + opts.resultItemWrapper).
/*
* комментарий
*/
prop(\'outerHTML\').
replace(/\\s+/g, \' \');
$(this).children().remove();
$(this).css({\'height\': \'100%\'});
// $(this).append
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);