// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)(\/\/(.*?)\n)|(\/\*(.*?)\*\/)").unwrap();
let string = "/* комментарий */
init: function(options)
{
opts = $.extend({}, defaults, options);
opts._this = $(this).attr('id');
opts.elementWrapper = $('#' + opts.resultItemWrapper).
/*
* комментарий
*/
prop('outerHTML').
replace(/\\s+/g, ' ');
$(this).children().remove();
$(this).css({'height': '100%'});
// $(this).append
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}