#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=.*")-%|(?=.*")%-"
Local $sString = "{%- assign foo = true -%}" & @CRLF & _
"" & @CRLF & _
"<span class="{%- if foo == true -%} blue{%- else -%} red{%- endif -%}">item</span>"
Local $sSubst = "%"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)