using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*"")-%|(?=.*"")%-";
string substitution = @"%";
string input = @"{%- assign foo = true -%}
<span class=""{%- if foo == true -%} blue{%- else -%} red{%- endif -%}"">item</span>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}