const regex = /(?=.*")-%|(?=.*")%-/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*")-%|(?=.*")%-', 'gm')
const str = `{%- assign foo = true -%}
<span class="{%- if foo == true -%} blue{%- else -%} red{%- endif -%}">item</span>`;
const subst = `%`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);