use strict;
my $str = '{%- assign foo = true -%}
<span class="{%- if foo == true -%} blue{%- else -%} red{%- endif -%}">item</span>';
my $regex = qr/(?=.*")-%|(?=.*")%-/mp;
my $subst = '%';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";