re = /(?=.*")-%|(?=.*")%-/m
str = '{%- assign foo = true -%}
<span class="{%- if foo == true -%} blue{%- else -%} red{%- endif -%}">item</span>'
subst = '%'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result