$re = '/(?=.*")-%|(?=.*")%-/m';
$str = '{%- assign foo = true -%}
<span class="{%- if foo == true -%} blue{%- else -%} red{%- endif -%}">item</span>';
$subst = "%";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;