# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?(?:\d+(?:\.\d+)?).*?\K\d+(?:\.\d+)?//gmi;t' <<< "fname <-'FS1_SCN0.83_axg3.csv"