$re = '/^.*?(?:\d+(?:\.\d+)?).*?\K\d+(?:\.\d+)?/mi';
$str = 'fname <-\'FS1_SCN0.83_axg3.csv';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;